1080 Graduate Admission 30 ☆☆★

github 地址:https://github.com/iofu728/PAT-A-by-iofu728 难度:☆☆★ 关键词:sort

题目

1080 Graduate Admission(30) It is said that in 2011, there are about 100 graduate schools ready to proceed over 40,000 applications in Zhejiang Province. It would help a lot if you could write a program to automate the admission procedure.

Each applicant will have to provide two grades: the national entrance exam grade GE, and the interview grade GI. The final grade of an applicant is (GE+GI)/2. The admission rules are:

The applicants are ranked according to their final grades, and will be admitted one by one from the top of the rank list.

If there is a tied final grade, the applicants will be ranked according to their national entrance exam grade GE. If still tied, their ranks must be the same.

Each applicant may have K choices and the admission will be done according to his/her choices: if according to the rank list, it is one's turn to be admitted; and if the quota of one's most preferred shcool is not exceeded, then one will be admitted to this school, or one's other choices will be considered one by one in order. If one gets rejected by all of preferred schools, then this unfortunate applicant will be rejected.

If there is a tied rank, and if the corresponding applicants are applying to the same school, then that school must admit all the applicants with the same rank, even if its quota will be exceeded.

Input Specification: Each input file contains one test case.

Each case starts with a line containing three positive integers: N (≤40,000), the total number of applicants; M (≤100), the total number of graduate schools; and K (≤5), the number of choices an applicant may have.

In the next line, separated by a space, there are M positive integers. The i-th integer is the quota of the i-th graduate school respectively.

Then N lines follow, each contains 2+K integers separated by a space. The first 2 integers are the applicant's GE and GI, respectively. The next K integers represent the preferred schools. For the sake of simplicity, we assume that the schools are numbered from 0 to M−1, and the applicants are numbered from 0 to N−1.

Output Specification: For each test case you should output the admission results for all the graduate schools. The results of each school must occupy a line, which contains the applicants' numbers that school admits. The numbers must be in increasing order and be separated by a space. There must be no extra space at the end of each line. If no applicant is admitted by a school, you must output an empty line correspondingly.

Sample Input: 11 6 3 2 1 2 2 2 3 100 100 0 1 2 60 60 2 3 5 100 90 0 3 4 90 100 1 2 0 90 90 5 1 3 80 90 1 0 2 80 80 0 1 2 80 80 0 1 2 80 70 1 3 2 70 80 1 2 3 100 100 0 2 4 Sample Output: 0 10 3 5 6 7 2 8

1 4

大意

模拟志愿录取系统,n 个考生,每个考生有两门课成绩,可以填写 k 个志愿。有 m 所学校,每个学校有对应的招生名额。 考生成绩按总分从上到下排序,如果同总分,第一门课高的排名高;如果所有成绩相同,则排名一样。 如果同一排名的考生,填写了同样的志愿,只要学校还有一个名额,必须把同分同志愿的一起录取

思路

  1. 还是很典型的 sort 题,建立 struct 存储相关的分数,排名,志愿;
  2. 先对考生成绩按规则排序,完全同分按 id;
  3. 按排名遍历志愿,有空位则进;
  4. 若学校招生名额<=实际招生人数,则比较最后一个节点排名是否与当前节点排名一致,若一致,则进队列
  5. 对结果队列按 id 排序输出;

code

#include <algorithm>
#include <iostream>
#include <vector>

using namespace std;

struct node {
  int ge, gi, rank, id;
  vector<int> application;
};

bool comparenode(node a, node b) {
  return a.ge + a.gi == b.ge + b.gi ? (a.ge == b.ge ? a.id < b.id : a.ge > b.ge)
                                    : a.ge + a.gi > b.ge + b.gi;
}

bool compareplace(node a, node b) { return a.id < b.id; }
int main(int argc, char const *argv[]) {
  int n, m, k, want;
  cin >> n >> m >> k;
  vector<int> places(m);
  vector<node> v;
  vector<vector<node> > result(m);
  for (int i = 0; i < m; ++i) cin >> places[i];
  for (int i = 0; i < n; ++i) {
    node temp;
    temp.id = i;
    cin >> temp.ge >> temp.gi;
    for (int i = 0; i < k; ++i) {
      cin >> want;
      temp.application.push_back(want);
    }
    v.push_back(temp);
  }
  sort(v.begin(), v.end(), comparenode);
  for (int i = 0; i < n; ++i) {
    if (i) {
      if (v[i].ge == v[i - 1].ge && v[i].gi == v[i - 1].gi) {
        v[i].rank = v[i - 1].rank;
        for (int j = 0; j < v[i].application.size(); ++j) {
          want = v[i].application[j];
          if (places[want] > result[want].size() ||
              (places[want] <= result[want].size() &&
               result[want][places[want] - 1].rank == v[i].rank)) {
            result[want].push_back(v[i]);
            break;
          }
        }
      } else {
        v[i].rank = i;
        for (int j = 0; j < v[i].application.size(); ++j) {
          want = v[i].application[j];
          if (places[want] > result[want].size()) {
            result[want].push_back(v[i]);
            break;
          }
        }
      }
    } else {
      v[i].rank = 0;
      result[v[i].application[0]].push_back(v[i]);
    }
  }
  for (int i = 0; i < m; ++i) {
    sort(result[i].begin(), result[i].end(), compareplace);
    for (int j = 0; j < result[i].size(); ++j) {
      if (j) cout << ' ';
      cout << result[i][j].id;
    }
    cout << endl;
  }

  return 0;
}

``
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
You can use this BibTex to reference this blog if you find it useful and want to quote it.