1075 PAT Judge 25 ☆☆☆

github 地址:https://github.com/iofu728/PAT-A-by-iofu728 难度:☆☆☆ 关键词:sort

题目

1075.PAT Judge(25) The ranklist of PAT is generated from the status list, which shows the scores of the submissions. This time you are supposed to generate the ranklist for PAT.

Input Specification: Each input file contains one test case. For each case, the first line contains 3 positive integers, N (≤10^4), the total number of users, K (≤5), the total number of problems, and M (≤10^5), the total number of submissions. It is then assumed that the user id's are 5-digit numbers from 00001 to N, and the problem id's are from 1 to K. The next line contains K positive integers p[i] (i=1, ..., K), where p[i] corresponds to the full mark of the i-th problem. Then M lines follow, each gives the information of a submission in the following format:

user_id problem_id partial_score_obtained where partial_score_obtained is either −1 if the submission cannot even pass the compiler, or is an integer in the range [0, p[problem_id]]. All the numbers in a line are separated by a space.

Output Specification: For each test case, you are supposed to output the ranklist in the following format:

rank user_id total_score s[1] ... s[K] where rank is calculated according to the total_score, and all the users with the same total_score obtain the same rank; and s[i] is the partial score obtained for the i-th problem. If a user has never submitted a solution for a problem, then "-" must be printed at the corresponding position. If a user has submitted several solutions to solve one problem, then the highest score will be counted.

The ranklist must be printed in non-decreasing order of the ranks. For those who have the same rank, users must be sorted in nonincreasing order according to the number of perfectly solved problems. And if there is still a tie, then they must be printed in increasing order of their id's. For those who has never submitted any solution that can pass the compiler, or has never submitted any solution, they must NOT be shown on the ranklist. It is guaranteed that at least one user can be shown on the ranklist.

Sample Input: 7 4 20 20 25 25 30 00002 2 12 00007 4 17 00005 1 19 00007 2 25 00005 1 20 00002 2 2 00005 1 15 00001 1 18 00004 3 25 00002 2 25 00005 3 22 00006 4 -1 00001 2 18 00002 1 20 00004 1 15 00002 4 18 00001 3 4 00001 4 2 00005 2 -1 00004 2 0

Sample Output: 1 00002 63 20 25 - 18 2 00005 42 20 0 22 - 2 00007 42 - 25 - 17 2 00001 42 18 18 4 2 5 00004 40 15 0 25 -

大意

根据最好成绩排名,如果没有一个编译通过不输出;如果编译不通过,显示 0;未提交显示‘-’;同分,按最多满分数进行倒序,id 正序

思路

  1. 就是一个 verctor 加 struct 的 sort 问题,关键点在于 compare 函数,和过滤条件;
  2. 需要对编译不通过和不提交,两个问题进行仔细分析;
  3. 加上排名

code

#include <algorithm>
#include <cstdio>
#include <iostream>
#include <vector>

using namespace std;

struct node {
  int id, sum = 0, grade[5] = {-1, -1, -1, -1, -1}, perferNum = 0;
  bool havePush = false;
};

bool compareNode(node a, node b) {
  return a.sum == b.sum
             ? (a.perferNum == b.perferNum ? a.id < b.id
                                           : a.perferNum > b.perferNum)
             : a.sum > b.sum;
}

int main(int argc, char const *argv[]) {
  int n, k, m, uid, cid, tempGrade, rank = 1;
  cin >> n >> k >> m;
  std::vector<node> userList(n);
  int totalGrade[k];
  for (int i = 0; i < k; ++i) cin >> totalGrade[i];
  for (int i = 0; i < m; ++i) {
    cin >> uid >> cid >> tempGrade;
    if (tempGrade == -1) {
      userList[uid - 1].id = uid;
      userList[uid - 1].grade[cid - 1] = 0;
    }
    if (userList[uid - 1].grade[cid - 1] < tempGrade) {
      userList[uid - 1].id = uid;
      if (userList[uid - 1].grade[cid - 1] != -1)
        userList[uid - 1].sum -= userList[uid - 1].grade[cid - 1];
      userList[uid - 1].sum += tempGrade;
      userList[uid - 1].grade[cid - 1] = tempGrade;
      if (tempGrade == totalGrade[cid - 1]) ++userList[uid - 1].perferNum;
      userList[uid - 1].havePush = true;
    }
  }
  sort(userList.begin(), userList.end(), compareNode);

  for (int i = 0; i < n; ++i) {
    if (userList[i].havePush) {
      if (i && userList[i].sum == userList[i - 1].sum) {
        cout << rank << ' ';
      } else {
        cout << i + 1 << ' ';
        rank = i + 1;
      }
      printf("%05d %d", userList[i].id, userList[i].sum);
      for (int j = 0; j < k; ++j) {
        if (userList[i].grade[j] == -1) {
          cout << " -";
        } else {
          cout << ' ' << userList[i].grade[j];
        }
      }
      if (i != n - 1) cout << endl;
    }
  }
  return 0;
}

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
You can use this BibTex to reference this blog if you find it useful and want to quote it.