1014 Waiting in Line 30 ★★★★

这是一个很有趣的题目,也有一些难度,很早以前就想讲了。和PAT A 1026,PAT A 1017是一个类型的题目,我称之排队问题,我在另外一篇“排队模拟问题分析”中会详细讲一下这类问题的思路。另外从这次博客开始,我在贴出来的代码中会放上我调试的一些过程,可能大家会和我出现一样的问题,仅提供解决思路。 github 地址:https://github.com/iofu728/PAT-A-by-iofu728 难度:★★★★ 关键词:排队问题,sort,模拟

题目

1014: Waiting in Line (30) Suppose a bank has N windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. The rules for the customers to wait in line are:

The space inside the yellow line in front of each window is enough to contain a line with M customers. Hence when all the N lines are full, all the customers after (and including) the (NM+1)st one will have to wait in a line behind the yellow line. Each customer will choose the shortest line to wait in when crossing the yellow line. If there are two or more lines with the same length, the customer will always choose the window with the smallest number. Customer[i] will take T[i] minutes to have his/her transaction processed. The first N customers are assumed to be served at 8:00am. Now given the processing time of each customer, you are supposed to tell the exact time at which a customer has his/her business done.

For example, suppose that a bank has 2 windows and each window may have 2 custmers waiting inside the yellow line. There are 5 customers waiting with transactions taking 1, 2, 6, 4 and 3 minutes, respectively. At 08:00 in the morning, customer1 is served at window1 while customer2 is served at window2. Customer3 will wait in front of window1 and customer4 will wait in front of window2. Customer5 will wait behind the yellow line.

At 08:01, customer1 is done and customer5 enters the line in front of window1 since that line seems shorter now. Customer2 will leave at 08:02, customer4 at 08:06, customer3 at 08:07, and finally customer5 at 08:10.

Input

Each input file contains one test case. Each case starts with a line containing 4 positive integers: N (<=20, number of windows), M (<=10, the maximum capacity of each line inside the yellow line), K (<=1000, number of customers), and Q (<=1000, number of customer queries).

The next line contains K positive integers, which are the processing time of the K customers.

The last line contains Q positive integers, which represent the customers who are asking about the time they can have their transactions done. The customers are numbered from 1 to K.

Output

For each of the Q customers, print in one line the time at which his/her transaction is finished, in the format HH:MM where HH is in [08, 17] and MM is in [00, 59]. Note that since the bank is closed everyday after 17:00, for those customers who cannot be served before 17:00, you must output “Sorry” instead.

Sample Input 2 2 7 5 1 2 6 4 3 534 2 3 4 5 6 7

Sample Output 08:07 08:06 08:10 17:00 Sorry

大意

有 k 个人发了疯似的,不约而同的在 8 点前,到一家银行的窗口前排成 n 队列。但是人多了银行站不下,所以要求每个队列的第 m 之后的顾客,在休息区等候叫号。当前面的顾客办完业务之后,叫号区第一个进排列队列。给出 q 个查询点,问这 q 个人能在多久前办完业务。

思路

  1. 设一个 node 节点,存放每个队列的首位的离队时间 poptime--决定了什么时候能有人可以进队,末尾的离队时间 endtime---决定了后面的人能不能办完业务。
  2. 选择遍历顾客,分队列区和乘客区,两部分遍历。
  3. 用一个 bool 型来记录时候超时。
  4. 使用 sort 加 poptime 来选择队列进行排队。

code

#include <algorithm>
#include <iostream>
#include <queue>
#include <vector>
using namespace std;
struct node {
  int poptime = 0, endtime = 0, windows;
  queue<int> q; // 存入花费时间
};
bool cmp(node a, node b) { return a.poptime < b.poptime; }
int main() {
  int n, m, k, q, now = 1;
  cin >> n >> m >> k >> q;
  getchar();
  vector<int> spend(k + 1), end(k + 1);
  bool vis[k + 1] = {true}; // 能否服务判断
  fill(vis, vis + k + 1, true);
  //        for(int i=1;i<=k;++i){
  //        cout<<vis[i]<<" ";
  //    }
  //    cout<<endl;
  for (int i = 1; i < k + 1; ++i) {
    cin >> spend[i];
  }
  getchar();
  vector<node> window(n);
  // 遍历排队区
  for (int i = 1; i <= m; ++i) {
    for (int j = 1; j <= n; ++j) {
      if (now <= k) {
        window[j - 1].q.push(spend[now]);
        if (window[j - 1].endtime >= 540) {
          vis[now] = false; // 前面一位结束时候超时
        }
        window[j - 1].endtime += spend[now];
        if (i == 1) {
          window[j - 1].poptime = window[j - 1].endtime;
        }
        end[now] = window[j - 1].endtime;
        window[j - 1].windows = j - 1;
        ++now;
      }
    }
  }
  //    for(int i=0;i<n;++i){
  //        cout<<window[i].poptime<<" "<<window[i].endtime<<" ";
  //        for(int j=0;j<m;++j){
  //            int temp=window[i].q.front();
  //            cout<<temp<<" ";
  //            window[i].q.pop();
  //        }
  //        cout<<endl;
  //    }
  //    for(int i=1;i<=k;++i){
  //        cout<<vis[i]<<" ";
  //    }
  //    cout<<endl;
  // 遍历等待区
  while (now <= k) {
    sort(window.begin(), window.end(), cmp);
    window[0].q.pop();
    int temptime = window[0].q.front();
    window[0].poptime += temptime;
    if (window[0].endtime >= 540)
      vis[now] = false;
    window[0].endtime += spend[now];
    window[0].q.push(now);
    end[now] = window[0].endtime;
    ++now;
  }
  //    for(int i=1;i<=k;++i){
  //        cout<<vis[i]<<" ";
  //    }
  for (int i = 0; i < q; ++i) {
    int temp;
    scanf("%d", &temp);
    if (vis[temp] == false)
      cout << "Sorry\n";
    else {
      printf("%02d:%02d\n", (end[temp] / 60 + 8), (end[temp] % 60));
    }
  }
  return 0;
}

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
You can use this BibTex to reference this blog if you find it useful and want to quote it.