1079 Total Sales of Supply Chain 25 ☆☆☆

github 地址:https://github.com/iofu728/PAT-A-by-iofu728 难度:☆☆☆ 关键词:BFS/DFS

题目

1079 Total Sales of Supply Chain(25) A supply chain is a network of retailers, distributors, and suppliers -- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one's supplier in a price P and sell or distribute them in a price that is r% higher than P. Only the retailers will face the customers. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the total sales from all the retailers.

Input Specification: Each input file contains one test case. For each case, the first line contains three positive numbers: N (≤10^5), the total number of the members in the supply chain (and hence their ID's are numbered from 0 to N−1, and the root supplier's ID is 0); P, the unit price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then N lines follow, each describes a distributor or retailer in the following format:

Ki ID[1] ID[2] ... ID[Ki]

where in the i-th line, Ki is the total number of distributors or retailers who receive products from supplier i, and is then followed by the ID's of these distributors or retailers. Kj being 0 means that the j-th member is a retailer, then instead the total amount of the product will be given after Kj. All the numbers in a line are separated by a space.

Output Specification: For each test case, print in one line the total sales we can expect from all the retailers, accurate up to 1 decimal place. It is guaranteed that the number will not exceed 10^10.

Sample Input: 10 1.80 1.00 3 2 3 5 1 9 1 4 1 7 0 7 2 6 1 1 8 0 9 0 4 0 3 Sample Output: 42.4

大意

给出一个经销商分销关系网及零售商销售份额,总经销商成本 p,每往下一级,价格增加 r%,求所有零售商销售总额

思路

  1. 首先这是一个树的题(不是图),需要建树;
  2. 求零售商销售额,则需要遍历树,计算层数;

code

#include <cmath>
#include <iostream>
#include <vector>

using namespace std;

double result = 0.0, p, r;

struct node {
  int volume;
  vector<int> child;
};

vector<node> v;

void dfs(int node, int depth) {
  if (!v[node].child.size()) {
    result += v[node].volume * pow(1 + r, depth);
  }
  for (int i = 0; i < v[node].child.size(); ++i) {
    dfs(v[node].child[i], depth + 1);
  }
}

int main(int argc, char const *argv[]) {
  int n, num, child;
  cin >> n >> p >> r;
  v.resize(n);
  r /= 100;
  for (int i = 0; i < n; ++i) {
    cin >> num;
    if (!num) {
      cin >> v[i].volume;
    } else {
      for (int j = 0; j < num; ++j) {
        cin >> child;
        v[i].child.push_back(child);
      }
    }
  }
  dfs(0, 0);
  printf("%.1f", result * p);
  return 0;
}

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
You can use this BibTex to reference this blog if you find it useful and want to quote it.